Urgent Epson Printer Help Needed

Decorating By kickasscakes Updated 12 May 2009 , 6:39pm by renee2007

kickasscakes Cake Central Cake Decorator Profile
kickasscakes Posted 12 May 2009 , 6:27pm
post #1 of 4

Hi all,

I Have an Epson Stylus CX7400 printer, used it a few times for edible images already. I have a cake due tomorrow, and I cannot get the printer to print the image. There is an error message saying that the magenta ink is low... I pulled it out, tapped it a bit to loosen it all up inside (lots of good ink inside)

Tried again, error message says that there are non facotry ink cartridges loaded, and it won't print. The printer ink light is blinking too.

Help, anyone?

3 replies
tiggy2 Cake Central Cake Decorator Profile
tiggy2 Posted 12 May 2009 , 6:33pm
post #2 of 4

Sounds like you need to reset the chip. Call kopykake and they may be able to help you. You might try taking it out several times and putting it back in, that has worked for me before. Just be sure it clicks all the way in.

adonisthegreek1 Cake Central Cake Decorator Profile
adonisthegreek1 Posted 12 May 2009 , 6:37pm
post #3 of 4

I had that problem when I first order my Epson printer. Do you have Kopykake? I called them and they had me take the chip off of the Epson ink cartridge that came with that printer and put it onto the edible ink cartridge. If you have Kopykake you can call them and they are really good about helping you.

renee2007 Cake Central Cake Decorator Profile
renee2007 Posted 12 May 2009 , 6:39pm
post #4 of 4

Hi, I have the same printer and have also had that message pop up when I first put in new edible ink cartridges and there should be some kind of question asking if you wish to continue or cancel. if you click yes, or continue you shouldn't have that message pop up any more and you should be able to print. hth icon_smile.gif

Quote by @%username% on %date%