Royal Icing!!!!! Ughh!

Baking By charlieinMO Updated 3 Oct 2014 , 3:39pm by charlieinMO

charlieinMO Posted 13 Sep 2014 , 7:43pm
post #1 of 6

I don't know what I am doing wrong!  I have made a ton of royal icing.  But the last few weeks I have been having issues!!  I tried a new meringue and thought that was it,  washed bowls and paddles over to make sure, didn't add any extra flavorings, and STILL it's not getting to the thick fluffly stage.  Yesterday 1 out of 3 batches worked!  Any ideas??!!  



I should say that I am using Antonia's recipe.

5 replies
-K8memphis Posted 1 Oct 2014 , 4:05pm
post #2 of 6

too much liquid?

virago Posted 1 Oct 2014 , 5:01pm
post #3 of 6

you're in Missouri right?...are you currently experiencing wide changes in humidity levels/dew points? add an extra TBS of meringue powder when mixing up the liquid portion.


wipe ALL your equipment down with lemon juice...bowls, containers, paddle/whisk attachments, mixing utensils, measures, tips, etc...everything that comes/will come in contact with anything you are working with. don't use plastic containers/piping bags unless they are new or have never been used for anything but royal icing.



Apti Posted 1 Oct 2014 , 6:36pm
post #4 of 6

Recently I made a batch of lemon swiss meringue buttercream and had a lot of zested, squeezed lemon halves left over.  Instead of throwing them away, I kept them in the fridge and the next day I placed them in a large bowl that I wiped down with one of the lemon rinds, then filled the bowl with water and floated all the used lemon halves in the bowl.  After I did my initial cleaning in one side of the sink, I put the "clean" utensils and beaters in the lemon water. 


The theory is that the lemon water may get rid of any oils missed during the cleaning with soap and water.


It also made the kitchen smell good.

MBalaska Posted 1 Oct 2014 , 7:08pm
post #5 of 6


Originally Posted by Apti 

Recently I made a batch of lemon swiss meringue buttercream ............."

@Apti was your SMBC wonderful? are you loving it?


@charlieinMO what is your idea about what is wrong?  What do you suspect as the problem.

charlieinMO Posted 3 Oct 2014 , 3:39pm
post #6 of 6

Sorry all.  It just sent me a message that you all had replied.   Well, I am really embarrassed to say that I finally figured out part of the problem.  I was using the wrong measuring cup for the water!!!!   The 1/3 cup instead of the 1/4 Ughhh.  Guess it was not a good day!!  Can only laugh about it now. lol.  


I did make some two days ago and it still didn't mix up like normal.  I'm thinking the weather has something to do with it.  It's been raining for a few days now!  A lot! 


I will try the lemon suggestion!


Thanks so much everyone!!


Quote by @%username% on %date%