Italian Meringue Troubleshooting?

Decorating By goforbroke510 Updated 8 Jan 2014 , 8:35pm by goforbroke510

goforbroke510 Posted 8 Jan 2014 , 8:13pm
post #1 of 3

Been having some problems with my Italian Meringue.

 

It doesn't happen when I make a large batch, but it happens with I make a smaller batch (which is still a lot).

 

I whip my egg whites until soft ball stage (until a ball forms inside the whisk).

I cook my sugar syrup to 116-118 degrees celcius.

 

I pour the sugar syrup into my egg whites while the egg whites are whipping at speed 10 on a kitchenaid mixer. I usually pour where the egg whites meet the side of the bowl.

 

I lower the speed to 8 and whip until the bowl is room temperature.

 

Now, when I make a LARGE batch, it comes out nice and fluffy and glossy. This is with about 300g of sugar. When I half the batch and use 150g of sugar and pour it into my egg whites, I get all these sugar granules stuck to the bottom of my mixer bowl, and when I scrape the meringue out, sometimes there is bits and pieces of sugar granules in the meringue. But it doesn't happen when I make a big batch.

 

What am I doing wrong? Cooking the sugar too much?

2 replies
liz at sugar Posted 8 Jan 2014 , 8:22pm
post #2 of 3

I cook my sugar a little hotter - 250 degrees Fahrenheit.  I pour in slowly while Kitchenaid is on a lower speed - maybe 4?  I'm not sure of the setting.  But I know it isn't on 8 or 10.

 

I have the opposite problem - I like my Artisan better than my 7 qt for Italian Meringue.  It doesn't seem to get stiff enough in the bigger mixer.

 

Liz

goforbroke510 Posted 8 Jan 2014 , 8:35pm
post #3 of 3

Quote:

Originally Posted by liz at sugar 
 

I cook my sugar a little hotter - 250 degrees Fahrenheit.  I pour in slowly while Kitchenaid is on a lower speed - maybe 4?  I'm not sure of the setting.  But I know it isn't on 8 or 10.

 

I have the opposite problem - I like my Artisan better than my 7 qt for Italian Meringue.  It doesn't seem to get stiff enough in the bigger mixer.

 

Liz

I wasn't sure if it was because I reduced the amount of water I added to the sugar when making the sugar syrup. Normally when I make a large batch, it's 300g sugar and 75g water. My original recipe called for 150g sugar and 50g water but I reduced the water to 35-40g. 

 

I also figured the speed needed to be higher to quickly incorporate the sugar syrup into the meringue.. perhaps I'll try lowering the speed.

 

I make both batches in my 5qt.

Quote by @%username% on %date%

%body%