KKristy Posted 13 Jun 2011 , 1:09pm
post #1 of

I was wondering if there is a product issue with FMM (manufacturer of tappits) - many of the letter tappits are constantly out of stock - not just at GSA, all companies that I've tried to purchase these through...I already have a few sets ( and love them) but need more. Has anyone heard anything?

7 replies
mena2002 Posted 20 Jun 2011 , 4:36am
post #2 of

I haven't heard anything, but maybe everyone orders them that they are out of stock. If there was something wrong with them they would probably remove them all together?

joycesdaughter111 Posted 20 Jun 2011 , 4:57am
post #3 of

If you can't get Tappits, there's new letters called Windsor Clicksticks that have a built in ejector you could try. thumbs_up.gif

luckyblueeye Posted 30 Jun 2011 , 11:13pm
post #4 of

I ordered my funky tappits on amazon a couple of weeks ago. I just watched a video on clikstix and they look much easier to use due to the built in plunger.

WeezyS Posted 15 Jul 2011 , 2:40am
post #5 of

Where did you find the video to watch? I would love to see how to use these. They sound great. Can you use them with fondant, or just gumpaste?

luckyblueeye Posted 15 Jul 2011 , 8:49pm
post #6 of

WeezyS, just google it and it'll come up...youtube I think. I've used with both fundant and gumpaste, but you need to let your fondant sit for about 10 min before using the cutters (unless you're using shortening and need to let them dry), I think that gumpaste is easier. Be 100% that the fondant or gumpaste isn't sticking to your counter and use some PS to make the release very easy.

WeezyS Posted 16 Jul 2011 , 12:51am
post #7 of

Thanks luckeyblueye. I did google it ,and found it. I thumbs_up.gif t was very helpful. Thanks for your help. I can't wait to order these. I am terrible at writing on cakes and these will be such a big help!

madis_granny Posted 16 Jul 2011 , 1:08am
post #8 of

Bakers Kitchen has them http://www.thebakerskitchen.net/
I ran into the same problem about a month ago when trying to find them.

Quote by @%username% on %date%

%body%