Why Do Some Cleaning Spray Bottles Not Work?

Lounge By maggiev777 Updated 5 Dec 2009 , 5:23am by creative101

maggiev777 Posted 4 Dec 2009 , 11:53am
post #1 of 2

When I use my Windex, the spray bottle works awesome - lots of windex comes out, good coverage on the surface I'm cleaning, and none drips from the spout. I love that!

But when I use my Tilex (mold/mildew remover) or my OxiClean laundry stain remover (or some other products, those are just the two I can think of at the moment), the sprayer barely works. I have to push the sprayer thingy like 20 times and most of the time nothing comes out, sometimes bubbly foam builds up on the nozzles as I pump, and occasionally a good spray will come out. Why is that?? It drives me crazy and I can hardly use the product.

(and yes, I'm holding the bottle upright, and there is plenty left in the bottle, so I know the sprayer straw thingy is down in the cleaning fluid)

I've considered buying new sprayer bottles to put these things in, but I haven't done that because -
1) they are chemicals so I am nervous about just putting them in some random cheap container not intended for them, and
2) the empty spray bottles I've bought in the past always "stream" as opposed to "spray" - I want it to spray!

1 reply
creative101 Posted 5 Dec 2009 , 5:23am
post #2 of 2

try squeezing the bottle while spraying at the same time. you dont have to keep doing it. just for a couple of sprays. sometimes the fluid needs to be fed up through the straw. my hubby taught me that when i gripped about the nozzles not spraying. It may work it may not but hey its worth a try right? icon_razz.gif

Quote by @%username% on %date%

%body%