Please Help Quick! Specks/chunks In Choc Fondant, Semihomema

Decorating By mom2spunkynbug Updated 13 Jun 2009 , 1:59pm by mbt4955

mom2spunkynbug Posted 13 Jun 2009 , 5:12am
post #1 of 3

There's something wrong with my fondant! I put chocolate clay into Satin Ice white fondant and now there are little specks/chunks of chocolate in the fondant! It IS brown, but there's just millions of specks. Not what I expected. I made choc fondant before and this never happened (but I also made my own vanilla fondant base). Any suggestions???

It's late & I'm tired & I thought I would've been done by now! icon_cry.gif

2 replies
emrldsky Posted 13 Jun 2009 , 1:54pm
post #2 of 3

My only thought is that chocolate clay and fondant are not the same thing, so mixing them might be the culprit. If you had mixed chocolate fondant into Satin Ice, it should have been fine.

HTH!

mbt4955 Posted 13 Jun 2009 , 1:59pm
post #3 of 3

I haven't ever tried this with Satin Ice - haven't ever tried Satin Ice at all icon_smile.gif - but I have used the process and I think I've read about something similar. You might zap it in the microwave to melt the little specks that aren't mixing. I would think 15 seconds, then knead, 15 seconds, then knead. You might even have to get it fairly soft and then let it set up again.

If your chocolate clay was fine and you are using purchased fondant, it sounds like the chocolate just isn't quite where it needs to be. Good luck with this and maybe someone who actually knows will jump in and give you some advice. icon_smile.gif

Quote by @%username% on %date%

%body%