Decorating By stefkovic Updated 11 Dec 2014 , 12:47pm by Acadia

stefkovic Cake Central Cake Decorator Profile
stefkovic Posted 25 Apr 2013 , 3:06am
post #1 of 5

Does anyone use this website. I have been on it a couple times but have a really hard time getting to the tutorials. Have seen alot of post from this website on pinterest but when I click on the link I go to the main page but can't get any further. Any help or advice?

4 replies
amago Cake Central Cake Decorator Profile
amago Posted 26 Apr 2013 , 11:18pm
post #2 of 5

I use it quite often! You just reload the page, again if it turns out blank, and eventually the tutorial will appear! Just be patient!icon_smile.gif You have hundreds of nice tutorials there, it's addictive!

Goreti Cake Central Cake Decorator Profile
Goreti Posted 26 Apr 2013 , 11:33pm
post #3 of 5

That is a common problem with that site.  If you keep trying eventually you will get to the tutorials.  It's too bad because that site has tons of them.

rubyred625 Cake Central Cake Decorator Profile
rubyred625 Posted 20 Oct 2013 , 7:15pm
post #4 of 5

Athere is a limit to the website usage. if you give it a couple of days the tutorials will appear. another advice is, if you access the website on google, the tutorial will give you the option to translate in English. its a good website.

Acadia Cake Central Cake Decorator Profile
Acadia Posted 11 Dec 2014 , 12:47pm
post #5 of 5

I haven't been able to get to this website in months and months.  The tutorials I find online, and the ones in my bookmarks take me to a page that tells me to click on a banner to be taken to another site where I have to pay to use.  When I click on the banner to get more information, it is indicated that the original site is still FREE, but any new tutorials are being added to the paid premium site.  But I can't access the free one anymore.

Here is what I see.  I've tried different browsers and have cleared internet cookies. I even tried a proxy server to see if I was banned from the site for some reason. All results are the same. I still can't get there.

This is ongoing for months and months, no matter what time of the day I try, or how often I refresh the page. Always the same result.

Can anyone else access the page of tutorials?


Quote by @%username% on %date%