lesliemc Posted 9 Feb 2013 , 6:16pm
post #1 of

I made my first batch of Sugarveil last night - followed the directions exactly - 4 minutes on high using my KitchenAid stand mixer - but my product seems too stiff (both immediately after mixing and 18 hrs later).   It spreads great using various templates made from mylar, and pipes very well using traditional methods but it is IMPOSSIBLE to pipe using the piping unit sold by Sugarveil - the pressure just pops out the inserted cartridge, even when the Sugarveil is mixed again with a little water.  The screeching sound of the Sugarveil piping machine is rather unpleasant as well.   

 

Do you think it was mixed too long or too fast using the KitchenAid stand mixer?  Better to use a hand mixer?

 

Thanks

3 replies
emilyg Posted 9 Feb 2013 , 7:11pm
post #2 of

Hi Leslie,

 

Sounds like we need to take a look at your Icing Dispenser - your SugarVeil mixture sounds properly prepared. Can you pop the black handpiece with the clear tube in the mail to us at my attention [SugarVeil Products, P.O. Box 18, Waldron, MO 64092], with a note to remind me of this message? We'll take a look at what's happening and get it back to you right away. Sorry for your difficulties, but we'll make it right so you'll be able to enjoy the Icing Dispenser without delay (and we'll send a pack of SugarVeil to cover your postage). Thank you! 

lesliemc Posted 9 Feb 2013 , 9:02pm
post #3 of

Thanks for your quick and generous offer.

 

I'd hoped to have the unit working for V-day petit fours, but I will send it in.

 

Love Sugarveil for regular piping and for making flexible decorations with Mylar templates cut with my Cameo.  FUN!  

 

Again, thanks!

 

Best,

 

Leslie

kikiandkyle Posted 9 Feb 2013 , 11:02pm
post #4 of

Wow, what great service!

Quote by @%username% on %date%

%body%