charliecakes Posted 18 Sep 2011 , 9:47pm
post #1 of

okay...I love IMBC, have always made it but only made the chocolate version a few times and each time it was a disaster. For some reason, even after I make sure the meringue is cool, when I add the chocolate which is also cooled down well, the meringue starts to get all nasty and gross and seperated looking. This happens every single time. And if i try to whip it like crazy.....eventually it seems to seperate even more and start weeping liquid which settles in the bottom of the kitchen aide bowl. Help! Please! What am i doing wrong. I can make the vanilla/regular version of IMBC with my eyes closed but this chocolate flavor has me stumped

17 replies
3GCakes Posted 18 Sep 2011 , 10:00pm
post #2 of

I guess my first question would be are you using cracked eggs or cartoned egg whites.

I've had this happen and I use pastuerized egg whites. I ALWAYS use white chocolate and DON'T have this problem, but when I use regular chocolate I do.

icer101 Posted 18 Sep 2011 , 10:38pm
post #3 of

I make imbc and smbc and i have not had this problem. Sometimes i use real whites and then i use the carton ones. I melt my dark chocolate, after the meringue is ready , i then add it in. The chocolate is always , like room temp. Are you adding your dk, chocolate after the meringue is done. hth I always add what i want it to taste like, after the meringue is made.

charliecakes Posted 18 Sep 2011 , 11:13pm
post #4 of

thanks ladies and yes i'm adding my chocolate in after my meringue is ready and like 3GCakes....yes i dont have this problem when i add in white chocolate...only dark chocolate...i just dont have a clue and i'm using cracked egg whites but have also had this problem with the cartooned variety egg whites

3GCakes Posted 18 Sep 2011 , 11:15pm
post #5 of

Huh....SO add the chocolate before the butter?

charliecakes Posted 18 Sep 2011 , 11:33pm
post #6 of

no after the butter. I even had one person a while back tell me they mix their chocolate and butter together first then add it to the meringue. Well I tried this and low and behold it did the same things... same disaster.

3GCakes Posted 18 Sep 2011 , 11:35pm
post #7 of
Quote:
Originally Posted by charliecakes

no after the butter. I even had one person a while back tell me they mix their chocolate and butter together first then add it to the meringue. Well I tried this and low and behold it did the same things... same disaster.




Charliecakes, usually that is what I do...but from I read, Icer101, do you add it to the eggs, then the butter?

charliecakes Posted 18 Sep 2011 , 11:51pm
post #8 of

oh i see...maybe that's how icer is doing it...hmmm... i wonder.. I've had so many problems with this thing until i try like crazy to never make it but the chocolate IMBC is so tasty... I sure would like to figure this out.

charliecakes Posted 26 Sep 2011 , 4:24pm
post #9 of

anyone else...anyone???...all of you fellow imbc users out there....if you have any suggestions or advice I'd love to hear it. Thanks

LeanneW Posted 26 Sep 2011 , 5:04pm

I was following this thread because I use IMBC and thought this was interesting.

I've never had this problem and i was wondering if maybe it had to do with the vanilla, I always add vanilla to my chocolate frosting. I add the vanilla first, then melted chocolate.

I have a different problem with chocolate IMBC. When i add my melted chocolate I always seem to end up with a gritty textured BC. I have added the chocolate when the IMBC is still a bit warm, I have "tempered" the chocolate by adding a bit of IMBC into it before adding it to the batch, same problem.

So now to make chocolate IMBC I use cocoa powder, I mix it with just enough boiling water to make a paste, then add that to the batch. Of course, I don't have a way of making white choc IMBC now.

charliecakes Posted 28 Sep 2011 , 3:26am

Leanne W.. strangely enough.. the last batch I made which failed weeks ago when i posted this thread...i did try using cocoa powder instead of melted chocolate. I was sure that would do the trick but yet again it failed. I just don't know. It just doesn't seem to want to stay together...like the emulsification keeps breaking down and the icing starts to weep and get a lil watery and nasty looking.

icer101 Posted 28 Sep 2011 , 4:12am

will this help


http://babycakes-rachcummins.blogspot.com/2009/10/chocolate-swiss-meringue-buttercream.html

LeanneW Posted 28 Sep 2011 , 5:51pm

it sounds like there is just too much liquid involved, are you cooking your sugar to 238-240 degrees? there may be water left in your syrup contributing to the problem.

Also, just to check you are using butter right? not margarine or anything else?

once the batch breaks have you tried the trouble shooting techniques? I rarely have a batch break, and its is usually when incorporating fruit compounds or liquors but I have successfully brought it back by taking out one cup of the broken mixture, microwave for 10 seconds, or until melted, then with teh mixer on, pur it into the rest of the batch, this should bring it back together.

One last idea... what about adding ganache instead of melted chocolate?

WE ARE GOING TO SOLVE THIS MYSTERY!

charliecakes Posted 29 Sep 2011 , 1:31am

Thanks icer 101/I will try it this way with heating the sugar and egg whites together. And thanks LeanneW...I hate it when I cant figure something out and I know it's probably something so minor.. some small detail I'm doing wrong. lol

charliecakes Posted 29 Sep 2011 , 1:32am

and yes leanne i am using butter.. like i said.. the plain vanilla version of this i can make in my sleep. it's only the chocolate that gives me trouble

baby_weasel Posted 9 Jan 2013 , 11:05am

Guys...

I am having the same problem with dark chocolate. I figured out it's the same if I add some cream cheese... My guess is that the added ingredient contains too little fats, then the imbc curdles and breaks apart. Eventhough, if I add whiskey or alcohol that does not happen... I am not sure why...

Since this thread is from 2011... Did anyone of you come up with any solution in these years?

 

Thank you!

julzs71 Posted 9 Jan 2013 , 11:57am

AAre you letting your chocolate cool to room temp? That could melt the butter a tad bit, but if that happens, just put it in the fridge and rewhip. Also, I take out a bit of butter if I use chocolate, but that step is not necessary.

yortma Posted 9 Jan 2013 , 1:58pm

Very strange.  I have made chocolate buttercream many times and have never had that happen.  I used to make IMBC (RLB)  but now I always make SMBC.  But hard to imagine that would make a difference.  I just dump in melted cooled chocolate until it is the intensity I want.

 

1)  Are you using chocolate chips, or good quality chocolate?  My understanding is that chips are formulated to melt at a higher temperature, and maybe they don't emulsify as well with the buttercream.  

 

2) Is the completed buttercream at room temp when you mix in the chocolate?  If it is too cold when you rebeat it (with or without the added chocolate) it will break down irretrievabally

Quote by @%username% on %date%

%body%