Spectra Posted 8 Sep 2011 , 4:23pm
post #1 of

This is the first time that the royal icing on my cookies got 'splochy', barely noticeable, but it looks like little dots, a few mm in diametre, along the edges. Like parts of the icing got darker around the dots. Out of the same batch of icing I made purple, dark, with no problems, but this Sky Blue is getting splochy. Did I do something wrong?

4 replies
divinecc Posted 8 Sep 2011 , 4:47pm
post #2 of

How old is your color gel? Sometimes if mine is older it will leave specks in my frosting, RI etc.

Spectra Posted 8 Sep 2011 , 6:17pm
post #3 of

Hmm, I would say about a year and a half old.

globalgatherings Posted 10 Sep 2011 , 5:03am
post #4 of

That's been happening to me too. With the Americolor Super Red. Anywhere from 24 to 48 hours later my cookies start to get dark spots all over them. I think Sweetopia had a blog about it and they thought maybe the grease from the cookie started to seap thru. I don't think that's the problem but I have yet to figure it out??

I had made 3 dozen red dresses for a customer and I had to throw them out and make new ones that I covered with red sugar. This is a frustrating problem and by the time you figure out they are going to spot, you're screwed icon_cry.gif

Spectra Posted 10 Sep 2011 , 1:59pm
post #5 of

Yeah, I think it has something to do with the colours only because I made some cookies sky blue, some pink, and some purple, all iced the same day and only the blue got splotchy.

I will try buying a new sky blue and and do a few test cookies in that colour again, because that is the first time that has EVER happened, and the only thing that was different was I used this colour for the first time on cookies. Perhaps there was some grease in the colour from a previous use, and that is why it only affected those cookies. So weird.

Quote by @%username% on %date%

%body%