Wasc Disaster Please Help

Baking By notjustcake Updated 11 Aug 2011 , 5:02pm by KoryAK

notjustcake Posted 11 Aug 2011 , 1:04am
post #1 of 7

I just tried 2 recipes of the WASC recipe posted here that I have used over and over for years and today I already threw away 2 cakes!!!
DId I open the door too soon or is my oven not heating right, I already baked chocolate WASC cakes came out great!!

WASC recipe didn't seem to rise at all
used Betty Crocker mixes
cakes came out very hard and dry.

SO I'm trying it again cause I have no plan B my cakes have to be white
I threw away the bit of flour I had left opened a new box instead of 2 tablespoons of oil I added 1/4 of a cup like the cake mix box says
1 cup of flour salt sugar and sour cream crossing my fingers!!!

FYI Im baking 8" square cake right now gave the oven 40 minutes. at 325 degrees
What am I doing wrong please help!!!!!!!!!!!!

6 replies
caymancake Posted 11 Aug 2011 , 1:20am
post #2 of 7

Is the cake mix expired? I would check the box mix and try fresh flour...

kakeladi Posted 11 Aug 2011 , 1:24am
post #3 of 7

Are you using my *original* WASC recipe?
There is NO oil needed/used.
It sure sounds to me like it might be a problem w/your oven.
I don't think opening the door too soon unless you left it open for more than a few seconds/ up to a minute. Is you oven electric?
Could you be using one of the new BC mixes - with less weight and new mixing instdructions??

VaBelle Posted 11 Aug 2011 , 1:34am
post #4 of 7

I read a post last week where someone was saying that BC has less mix in their box now. Maybe that is why it didn't rise?

notjustcake Posted 11 Aug 2011 , 1:39am
post #5 of 7

check the box it expires in december

My other cakes baked just fine

can u post a link to the original wasc??

KoryAK Posted 11 Aug 2011 , 5:02pm
post #7 of 7

Yeah, make sure the amount of cake mix is what it's supposed to be because of the changes.

Quote by @%username% on %date%