Problem With My Buttercream Icing--Help

Baking By BakedCT Updated 24 Nov 2010 , 10:49am by AnnieCahill

 BakedCT  Cake Central Cake Decorator Profile
BakedCT Posted 23 Nov 2010 , 6:21pm
post #1 of 5

Ive been using this buttercream recipe and it comes out fine when I dont add food colouring. but the minute i add gel food coloring it goes all blotchy and looks horrible, almost as if its splitting?? And i dont know what I did wrong

Is it the colouring? I have been using gel food colouring from Americolor. Am i over beating it? I am using a Planetary Mini Industrial Cake mixer...i thought its my mixer but I even tried beating the ingredients with the machine and then using a spatula to add the colouring but that didnt help. Its so frustrating.

Can anyone help me out?

4 replies
 tastyart  Cake Central Cake Decorator Profile
tastyart Posted 23 Nov 2010 , 6:27pm
post #2 of 5

Are you saying that the color is blotchy in the frosting? How old is your color? I had some that got pretty old and it clumped and wouldn't mix in properly. HTH

 TexasSugar  Cake Central Cake Decorator Profile
TexasSugar Posted 23 Nov 2010 , 6:37pm
post #3 of 5

What is the icing recipe? Is your icing soft or thin to start with? And are you making dark colors?

 BakedCT  Cake Central Cake Decorator Profile
BakedCT Posted 24 Nov 2010 , 5:49am
post #4 of 5

They are new bottles of coloring. The recipe is 125g butter,250g icing sugar and 1 Tablespoon milk and optional 1 tsp vanilla.

I've tried making violet and then lastnight I made bright pink. The colour does mix through but its not smooth (difficult to explain) it just looks blotchy. I am thinking now if it isn't my mixer, before when I've made red and black icing it came out fine but then I used my hand mixer as my stand mixer was broken. Now that my stand mixer is fixed I've been using that-could it be too powerful? I'm actually going to try a batch with my hand mixer using the same colouring. Will post what happens.
Thanks

 AnnieCahill  Cake Central Cake Decorator Profile
AnnieCahill Posted 24 Nov 2010 , 10:49am
post #5 of 5

I think it's Americolor. It happens to me with blue and green. I am going to switch to Chefmaster and see if that helps.

Quote by @%username% on %date%

%body%