Ka Pasta Roller Misbehaving

Decorating By sillywabbitz Updated 28 Aug 2010 , 5:42pm by sillywabbitz

sillywabbitz Posted 28 Aug 2010 , 4:11pm
post #1 of 5

To those who use the KA pasta roller I need some input.
I started using mine and I absolutely love it. I'm rolling out gumpaste for flowers.

It worked well for a while then I noticed that as I got to thing and thing settings it started bunching or rufflilng along the middle section.

So I stopped the kitchen aid and it looked like it had a little gunk on it so I took a damp paper towel and cleaned it, ran it through the roller...ran dry paper towel over it and through the roller thinking that should do it.

But its still doing it once I get to about a 3 setting.

Any thoughts? Thanks in advanceicon_smile.gif

4 replies
WykdGud Posted 28 Aug 2010 , 4:35pm
post #2 of 5

Did you grease your rollers with shortening?

mmdiez10 Posted 28 Aug 2010 , 4:47pm
post #3 of 5

Wipe the rollers with a damp cloth, then grease (lightly) the rollers with shortening. Wipe off excess and just before you run the gumpaste through it, dust the rollers with cornstarch. This should help.

nonilm Posted 28 Aug 2010 , 4:48pm
post #4 of 5

That happened to me when the fondant/gumpaste was too thick. Maybe run through the larger settings once more?

I prefer to use powdered sugar instead of shortening.

sillywabbitz Posted 28 Aug 2010 , 5:42pm
post #5 of 5

Thanks everyone. I did not grease the rollers. I tried PS but the seemed to only work for 1 go. I'll try the shortening and running it through the larger setting twice before going to a thinner setting. Thank you so muchicon_smile.gif

Quote by @%username% on %date%

%body%