Urgent! My Bettercreme Not Whipping Up!

Baking By mixinvixen Updated 14 Dec 2008 , 4:07am by -K8memphis

mixinvixen Posted 13 Dec 2008 , 3:30pm
post #1 of 3

so far, i have alot of time and money in these neighborhood cupcakes, and i chose bettercreme for it's ease of use. the first batch i made whipped up in somehting like 5 minutes, clear to the top of my bowl. (bettercreme, vanilla pudding, milk, and vanilla spice rum liquid creamer)...unfortunately, the creamer tasted funky, didn't like it so down the drain the whole bowl went.

this second batch, i did the same recipe but changed it to "italian sweet creme creamer...it tastes to die for, but i can't get it to whip, no matter what! it won't even go over half way up the bowl...i added a bit more bettercreme in, maybe one cup, thinking i had overwhipped and made it go flat, NOTHING! i've whipped this now in spurts for a total of over 40 minutes probably!!! i even put it back in the fridge last night and hoped to let it get cold and whip it this morning...NOTHING!! WHAT CAN I DO!! if i can't get it to whip, theres another one going down the drain!

2 replies
mixinvixen Posted 14 Dec 2008 , 3:00am
post #2 of 3

update...tried again (third time!)...while it didn't whip up near as high as the first batch, it tastes so darn good...still can't figure out what happened to the second batch...any ideas yet?

also, if using the recipe with pudding and milk, how stable is it really?

-K8memphis Posted 14 Dec 2008 , 4:07am
post #3 of 3

I've only used it as a whipped cream. I've never added a bunch of other stuff. But maybe somebody smart will know.

Just off the top of my head I'd say the pudding pulled it down but it was in the first batch so that's not it...

Quote by @%username% on %date%

%body%