I Left Salt Of Out The Nfsc...problem?

Baking By lardbutt Updated 6 Sep 2008 , 11:24pm by toleshed

lardbutt Posted 3 Sep 2008 , 12:28pm
post #1 of 6

Will this be a huge problem? I have the first batch in the oven now and they don't look right! BUT, I did just notice I was baking at 325 instead of 350. I just changed the temp., but this batch may be lost.

Have any of you ever left out the salt? What happened?

Thanks, Sherri

5 replies
Kiddiekakes Posted 3 Sep 2008 , 12:29pm
post #2 of 6

I never add the salt and mine come out fine everytime!!!

lardbutt Posted 3 Sep 2008 , 12:34pm
post #3 of 6

Oh, thank you kiddiekakes! I will continue with the rest of the batch. I did however ruin the first ones. They actually spread! I guess the wrong temp. did that.

Thanks again, Sherri

indydebi Posted 6 Sep 2008 , 5:28am
post #4 of 6

Just adding that I never add salt to ANY sweet recipe ... cookies, brownies, cakes, fudge ... nothing.

I figure if I dont' take a salt shaker to it when I eat it, then there's no need to salt it before ... and I've never salted a brownie in my life! icon_biggrin.gif

lardbutt Posted 6 Sep 2008 , 1:38pm
post #5 of 6

I actually figured out why the first batch spread! Um.....I accidently put 3 cups of sugar instead of 2! icon_lol.gif

But, make no mistake, they tasted wonderful! (hehe) I'm still a little shaky from eating them, but they were good! icon_redface.gif

This is what I did with the second batch.

And indydebi, I love salt and sugar, so I might just try salting a brownie! icon_wink.gif

toleshed Posted 6 Sep 2008 , 11:24pm
post #6 of 6

oh those are sweet. I love them

Quote by @%username% on %date%