Toba Garett's Glace Icing - Need Help!

Baking By just_for_fun Updated 19 Jun 2008 , 3:24pm by azureblu

just_for_fun Posted 17 Jun 2008 , 6:15am
post #1 of 4

So, I've been hearing only good things about this icing, so for my first paid cookie order, I decided to try it. BIG MISTAKE!! My dh says it tastes delicious, but no matter how much conf. sugar I add, it is runny. I put a dam around, but it's running from all sides. Also, many of the colors are not "catching" right, is it b/c those are Wilton? I did not concentrate if the ones that did not come out good were Wilton or not???

I just baked new cookies, mixed up RI, and stayed up til 2:15 am, I will finish in the morning icon_sad.gif They need this for tomorrow evening, was going to drop off in the middle of the day, will have to go out again later when it finishes drying..

If anyone has any ideas of why this did not work, I want to try it again!!

3 replies
karensue Posted 17 Jun 2008 , 2:15pm
post #2 of 4

This is how I've adjusted her recipe ..

1/2 cup water or milk
1 tsp. vanilla
1 tsp. almond flavoring
2 lbs. powdered sugar

Mix together. Will be very thick.

Add 1/2 cup white corn syrup. Mix 30-45 seconds.

This consistency works great for me. I don't outline, either.

I also use Americolor gels to color, but have used the Wilton colors and they worked fine.

just_for_fun Posted 19 Jun 2008 , 3:50am
post #3 of 4

Thanks so much, I will try this!

azureblu Posted 19 Jun 2008 , 3:24pm
post #4 of 4

If I may, I'd like to chime in with what I have learned (the hard way), I now only use either, "liquid paste" or powered colors. The gels are nice and I have some, but have a wetter(water) base. Also 'sift' that powered sugar!.

Its good to know someone also uses water, not milk in this formula...Azure

Quote by @%username% on %date%