Rich's Bettercream...not Holding Up After Defrost. Help!

Decorating By PhishTech Updated 29 Apr 2008 , 8:16pm by giggysmack

 PhishTech  Cake Central Cake Decorator Profile
PhishTech Posted 29 Apr 2008 , 5:27pm
post #1 of 5

I have been using the Bettercream (prewhipped and frozen) from Sams for about 8 months now. It worked perfect everytime until the last 3 or 4 cakes I have tried. I do the usual, pull from the freezer the amount I need and let it sit in the fridge overnight. Before applying to cake I smooth in bowl with a spatula a few times and apply but it seems to be soupy. I tried to add color to it last night...just a few drops and it is like it fell apart. REALLY soupy this time.

I have added color before and all is ok. I even tried buying a new bucket thinking maybe I got a bad batch, but same results.

Any ideas? I really love using it for ease and taste. I already have customers who request it regularly so I dont want to dissapoint them by telling them its not available anymore

Any help you can offer would be appreciated!

Thanks in advance!

4 replies
 JoAnnB  Cake Central Cake Decorator Profile
JoAnnB Posted 29 Apr 2008 , 7:56pm
post #2 of 5

have you tried re-whipping it?

 mjarvis78  Cake Central Cake Decorator Profile
mjarvis78 Posted 29 Apr 2008 , 8:03pm
post #3 of 5

The only thing I can think of is to make sure your bowl and whip are extra clean with no butter or anything like that on them.

 CakesByLJ  Cake Central Cake Decorator Profile
CakesByLJ Posted 29 Apr 2008 , 8:12pm
post #4 of 5
Quote:
Originally Posted by PhishTech

I have been using the Bettercream (prewhipped and frozen) from Sams for about 8 months now. It worked perfect everytime until the last 3 or 4 cakes I have tried. I do the usual, pull from the freezer the amount I need and let it sit in the fridge overnight. Before applying to cake I smooth in bowl with a spatula a few times and apply but it seems to be soupy. I tried to add color to it last night...just a few drops and it is like it fell apart. REALLY soupy this time.

I have added color before and all is ok. I even tried buying a new bucket thinking maybe I got a bad batch, but same results.

Any ideas? I really love using it for ease and taste. I already have customers who request it regularly so I dont want to dissapoint them by telling them its not available anymore

Any help you can offer would be appreciated!

Thanks in advance!




Your timing is so ironic... I have had the same problem with mine.. I got it from Sam's and never had this happen before.. When I whip it up before using it, it literally melts down.. You could beat it forever, but it does not revive it.. I am clueless too.. I have been using bettercream for years, and never had this problem before. Anyone else experience this?

 giggysmack  Cake Central Cake Decorator Profile
giggysmack Posted 29 Apr 2008 , 8:16pm
post #5 of 5

Probably a bad batch from Rich's. I would call them and ask them.

Quote by @%username% on %date%

%body%